Por el uso de Kernels obsoletos, cerca del 13% de los nuevos usuarios experimentan problemas de compatibilidad de hardware

Sin dudas uno de los grandes problemas en la relación Linux – nuevo usuario es el tema de la compatibilidad de hardware y aun que en cada nueva versión de Linux (cada dos meses) se añade más soporte, el problema continúa siendo un factor del porqué muchos usuarios terminan por alejarse de Linux.

Y es que estrictamente hablando del kernel, es decir, la parte que gestiona los recursos del ordenador y sirve como puente de comunicación entre los distintos componentes y es la parte invisible del sistema operativo, la versión más reciente no es incluida dentro de la mayoría de las distribuciones de Linux.

Además de que muchas de ellas se basan en la inclusión de versiones LTS o son enfocadas para equipos de bajos recursos, por lo que incluir la versión más reciente de Linux no es una opción viable.

La razón de tocar este tema, es que hace poco Linux-Hardware.org ha dado a conocer información con base en los datos telemétricos recopilados durante un año, que el uso de kernels «obsoletos» o «versiones anteriores» crea problemas de compatibilidad con el hardware para el 13% de los nuevos de los nuevos usuarios.

Un ejemplo bastante claro de la situación es la de la mayoría de los usuarios de Ubuntu en la cual durante el año pasado se les ofreció la versión 5.4 del kernel. Esto es más de un año y medio por detrás de la versión actual 5.13 en términos de soporte de hardware.

Mientras que por otro lado las distribuciones que son Rolling-Release (lanzamiento continuo) ofrecen no solo kernels más nuevos, sino que toda la paquetería del sistema está en constante actualización, pero el único y gran problema que sufren es su baja popularidad en comparación con otras distribuciones.

El propio Linus admite que esta es la razón por la que el sistema operativo está luchando por establecerse en la industria de las computadoras de escritorio.

Y aun que podríamos justificar que dicho número dado por Linux-Hardware.org no es exacto o que las cifras presentadas no representan a todos los usuarios de Linux, ya que en gran medida los resultados presentados están basados en recopilaciones propias de Linux-Hardware.org tomadas por todos aquellos que usaron la herramienta «hwinfo».-

Es decir, no todo usuario de Linux tiene la herramienta instalada y los resultados son basados en un grupo reducido de usuarios, pero aun asi las cifras presentadas son bastante decepcionantes.

Ya que por ejemplo en el area de dispositivos BT (bluetooth) las cifras mostradas nos diría que en esta area Linux cubre arriba del 95% (la más alta de todas las areas), pero de las demás areas las cifras mostradas simplemente son catastróficas.

Sobre el tema ya muchos usuarios han expresado sus experiencias sobre problemas de compatibilidad con Linux y aun que muchos usuarios han concordado que el uso de versiones anteriores a la más reciente de Linux les ha causado problemas con algún componente de hardware, lo que si llama la atención (al menos de manera personal) es que hay usuarios que exclaman lo contrario.

Es decir, que en el uso de la versión más reciente, llegan a tener problemas con algún componente de hardware, lo cual no debería de ocurrir, salvo que tu equipo sea de componentes de hace más de 20 años la situación sería razonable.

Tengo el problema opuesto con mi computadora portátil. Los kernels más nuevos que 5.0 hacen que el sistema se bloquee después de uno o dos minutos funcionando con la energía de la batería. Asumo algún tipo de problema de administración de energía, pero como no se producen registros, es básicamente imposible solucionarlo. Soy plenamente consciente de que 5.0 ya no es «compatible», pero «soporte» no significa nada si el sistema no funciona realmente.

Finalmente, debo mencionar que esta situación será el pan de cada día mientras los fabricantes de los componentes de hardware no sean quienes brinden el soporte para Linux y este es un caso bastante difícil que pueda suceder.

Si quieres conocer más al respecto, te invito a que puedas ver o unirte a la discusión creada dentro de los foros de reddit o puedas consultar la información que dio a conocer Linux-Hardware.org.

from Linux Adictos https://ift.tt/3ANfzlt
via IFTTT

Google Meet estrena los filtros, máscaras y estilos de Google Duo

Google Meet estrena los filtros, máscaras y estilos de Google Duo

Cuando la aplicación de videollamadas Google Meet llegó a todo el mundo hace poco más de un año muchos nos preguntamos qué pasaría con Google Duo. La posible respuesta llegó meses después con el rumor de que Duo sería absorbida por Meet, y esa absorción parece que acaba de comenzar.

El pasado mes de junio, Google Meet estrenó los efectos, permitiéndonos desenfocar y cambiar el fondo a nuestras videollamadas. Ahora este mes de junio llegan los filtros de Google Duo.


Continue reading