OpenWrt 21.02.0 llega con diversos cambios importantes, entre ellos los de hardware

Se acaba de presentar una nueva versión significativa de OpenWrt 21.02.0, la cual se destaca por haber aumentado los requisitos mínimos de hardware, ya que en la compilación predeterminada, debido a la inclusión de subsistemas de kernel de Linux adicionales, ahora se requiere un dispositivo con 8 MB de Flash y 64 MB de RAM para usar OpenWrt.

Aun que para los usuarios que tengan la intención de crear su propia compilación, aún pueden hacerlo para simplificar que pueda ejecutarse en dispositivos con 4 MB de Flash y 32 MB de RAM, pero la funcionalidad de dicha compilación será limitada y la estabilidad no está garantizada.

El paquete básico incluye paquetes para admitir la tecnología de seguridad inalámbrica WPA3, que ahora está disponible de forma predeterminada tanto cuando se trabaja en modo cliente como cuando se crea un punto de acceso. WPA3 proporciona protección contra ataques de fuerza bruta (no permite ataques de fuerza bruta en modo fuera de línea) y utiliza el protocolo de autenticación SAE. La mayoría de los controladores inalámbricos ofrecen capacidad WPA3.

Tambien el paquete básico incluye compatibilidad con TLS y HTTPS de forma predeterminada, lo que permite acceder a la interfaz web de LuCI a través de HTTPS y utilizar utilidades como wget y opkg para recuperar información a través de canales de comunicación cifrados. Los servidores a través de los cuales se distribuyen los paquetes descargados a través de opkg también están conmutados de forma predeterminada para proporcionar información a través de HTTPS.

La biblioteca mbedTLS utilizada para el cifrado se ha reemplazado por wolfSSL (si es necesario, puede instalar manualmente las bibliotecas mbedTLS y OpenSSL, que siguen proporcionándose como opciones). Para configurar el reenvío automático a HTTPS, se ofrece la opción «uhttpd.main.redirect_https =1» en la interfaz web.

Otro de los cambios que podremos encontrar, es que se implementó soporte inicial para el subsistema central DSA, que proporciona herramientas para configurar y administrar cascadas de switches Ethernet interconectados utilizando los mecanismos utilizados para configurar interfaces de red ordinarias (iproute2, ifconfig). DSA se puede utilizar para configurar puertos y VLAN en lugar de la herramienta swconfig sugerida anteriormente, pero no todos los controladores de conmutadores son compatibles con DSA todavía.

Se han realizado cambios en la sintaxis de los archivos de configuración ubicados en /etc/config/network. En el bloque «config interface», la opción «ifname» ha sido renombrada a «device», y en el bloque «config device», las opciones «bridge» e «ifname» han sido renombradas a «ports». Ahora se generan archivos separados con la configuración del dispositivo (capa 2, bloque «dispositivo de configuración») e interfaces de red (capa 3, bloque «interfaz de configuración») para nuevas instalaciones.

Para mantener la compatibilidad con versiones anteriores, se mantiene el soporte para la sintaxis anterior, es decir, las configuraciones creadas previamente no requerirán ningún cambio. En este caso, cuando se encuentre la sintaxis antigua en la interfaz web, se mostrará una propuesta para migrar a la nueva sintaxis, que es necesaria para editar la configuración a través de la interfaz web.

De los demás cambios que se destacan:

  • Se agregaron nuevas plataformas bcm4908 y rockchip para dispositivos basados ​​en SoC Broadcom BCM4908 y Rockchip RK33xx. Las plataformas con soporte previo tienen brechas fijas en la compatibilidad de dispositivos.
  • Se eliminó el soporte para la plataforma ar71xx, en lugar de la cual se debe usar la plataforma ath79 (para dispositivos vinculados a ar71xx, se recomienda reinstalar OpenWrt desde cero). Además, se suspendió la compatibilidad con las plataformas cns3xxx, rb532 y samsung (SamsungTQ210).
  • Los archivos ejecutables de las aplicaciones involucradas en el procesamiento de conexiones de red están construidos en modo PIE (Ejecutables independientes de la posición) con soporte completo para la aleatorización del espacio de direcciones (ASLR) para dificultar la explotación de vulnerabilidades en tales aplicaciones.
  • Al compilar el kernel de Linux, las opciones predeterminadas para admitir tecnologías de aislamiento de contenedores están habilitadas, lo que permite usar el kit de herramientas LXC y el modo procd-ujail en OpenWrt en la mayoría de las plataformas.
  • Proporcionó la capacidad de construir con soporte para el sistema de control de acceso forzado SELinux (deshabilitado por defecto).

Fuente: https://openwrt.org

from Linux Adictos https://ift.tt/3DPzukZ
via IFTTT