Flatpak 1.15 introduce soporte inicial para Meson

Flatpak 1.15

«Nuevo» logo de Flatpak

Hace unos instantes hemos publicado un artículo en el que os hablábamos de las sensaciones que nos dan los paquetes snap y flatpak. La frecuencia de las actualizaciones es algo en lo que los flatpak quedan por delante, lo que no siempre significa que sea mejor, y eso es algo que también podemos ver en el software que usan para empaquetar el software. Sólo dos meses después de la versión anterior, ya está disponible Flatpak 1.15.0.

Entre las novedades más destacadas, hay cambios en cuanto a la compilación: a partir de ahora este tipo de paquetes se puede compilar usando Meson en vez de Autotools. Para poder hacerlo es necesario usar Meson 0.53.0 o posterior y Python 3.5 o posterior. Según dicen, es probable que el sistema de construcción Autotools sea eliminado durante el ciclo de 1.15 o 1.17.

Otras novedades de Flatpak 1.15

Esta versión permite la llamada del sistema modify_ldt como parte de --alow=multiarch, lo que aumenta la superficie de ataque, pero es necesario al usar ejecutables de 16-bit en algunas versiones de WINE. También se puede compartir el socket gssproxy, lo que actúa como un portal para la autentificación de Kerberos y permite a las apps usar esta autentificación sin un agujero en el sandbox. Por último, se ha añadido una variable httpbackend a flatpak.pc, permitiendo a objetos dependientes como GNOME Software detectar si son compatibles con libflatpak.

Por otra parte, se han corregido estos errores:

  • Terminar los servicios flatpak-session-helper y flatpak-portal cuando la sesión, para que las aplicaciones no hereden direcciones de socket Wayland y las direcciones de los sockets X11.
  • Cuando se utiliza fish shell, no se sobrescribe un XDG_DATA_DIRS previamente establecido.
  • No intenta habilitar HTTP 2 si está vinculado a una versión de libcurl que no lo soporta.
  • Se detiene systemd reportando la sesión-ayudante como fallida cuando se termina por una señal.
  • Corregida una advertencia al listar un documento sin permisos.
  • Corregida la compilación con GLib 2.66.x (como se usa en Debian 11).
  • Corregida la compilación con GLib 2.58.x (como se usa en Debian 10).
  • Se ha hecho que los archivos generados sean más reproducibles.
  • Actualizaciones de traducción: cs, id, pl, pt_BR

Flatpak 1.15 se ha anunciado hace menos de 24 horas, y se puede descargar desde este enlace en GitHub, en donde se ha publicado toda la información sobre este lanzamiento. En los próximos días/semanas llegará a los repositorios oficiales de la mayoría de distribuciones Linux.

from Linux Adictos https://ift.tt/untFxPm
via IFTTT