postmarketOS 22.06.3 ha llegado como actualización de seguridad para corregir los problemas en WLAN

postmarketOS v22.06.3

Como ellos mismos dicen, los Service Pack de este sistema operativo llegan con novedades interesantes, pero esta vez no ha sido así a no ser que se entienda como «interesante» que es más seguro. En el SP del mes pasado sí se incluyeron mejoras notables, como que se subió a Phosh 0.21 y a Phoc 0.21.1. El postmarketOS 22.06.3 recién lanzado tiene una lista larga de novedades, pero en realidad se podrían resumir todas en dos, o una.

Todos los puntos de la lista menos uno dicen que han subido el kernel a una versión superior, siendo la elección en la mayoría de casos Linux 6.0.2. También hay casos en los que se ha subido a Linux 5.19 o una versión más nueva que ya incluye los parches, pero todos estos puntos se podrían resumir en que se ha actualizado el kernel para usar uno que ya tenga parcheados los problemas de seguridad en WLAN.

postmarketOS 22.06.3 no incluye nuevas funciones

Normalmente los service packs son para llevar las características de edge a estable, y las correcciones de seguridad se trasladan directamente a estable sin esperar a un service pack. Sin embargo, esta vez la corrección no era un parche trivial (como el de dirtypipe), y decidimos actualizar el kernel a la versión 6.0.2 cuando fuera posible. Esto requería más tiempo para el empaquetado y las pruebas, y tenía sentido agrupar todo esto en un paquete de servicio y hacer un anuncio adecuado al respecto. Así que aquí estamos.

El punto que falta, y en el que no se ha subido el kernel, ha sido para bajar la versión del núcleo que usaba el Nokia N900. El viejo rockero de Nokia (13 años va a hacer en las próximas semanas) estaba usando Linux 5.18.1, un kernel de ciclo normal que hace tiempo que ya ha llegado al final de su ciclo de vida. Podrían haberlo subido a Linux 5.19, si no fuera por una regresión en el USB que han descubierto recientemente. Por lo tanto, la única opción que les quedó fue bajar el kernel a Linux 5.15, la última versión LTS que sigue estando soportada.

Para instalar postmarketOS 22.06.3, hace ya un tiempo que se introdujo una herramienta para actualizar desde el terminal. Para el que no la tenga instalada, se puede añadir con el comando apk add postmarketos-release-upgrade, y luego lanzarla con el comando postmarketos-release-upgrade. Eso si se está en v21.12. Para versiones anteriores, los comandos de instalación serían:

wget https://gitlab.com/postmarketOS/postmarketos-release-upgrade/-/raw/master/upgrade.sh
chmod +x upgrade.sh

Las nuevas imágenes están disponibles en la página de descargas.

from Linux Adictos https://ift.tt/PaUqJHm
via IFTTT