Cómo forzar la recarga de un repositorio no firmado en Ubuntu y evita el «GPG error, ver apt-secure(8)»

GPG error o apt-secure(8)

Aunque los paquetes Flatpak están ganando popularidad con cada día que pasa, me atrevería a decir que la mayoría seguimos prefiriendo el software de repositorios estemos en las distribución que estemos. Por ese motivo es fácil que, por ejemplo, en Ubuntu añadamos un repositorio para tener la última versión de OBS Studio con sus dependencias más actualizadas. Pero, ¿qué pasa si lo hacemos y vemos el texto «GPG error»? Es algo que tiene solución.

Cuando vemos el GPG error o nos pide que veamos la página del manual apt-secure(8), lo que está pasando es que estamos intentando usar un repositorio no firmado, o sencillamente no está disponible para nuestra versión de Debian/Ubuntu. Esto puede pasar, por ejemplo, si estamos en un sistema que ya no recibe o aún no está soportado, como puede ser ahora mismo el Ubuntu 22.04 Jammy Jellifish que está en desarrollo. Hay que tener en cuenta que al forzar la recarga, estaremos saltándonos un aviso de seguridad, por lo que hay que tener cuidado con esto. Aunque usemos fuentes oficiales, como la de OBS o Pipewire, algo podría dejar de funcionar. No es un error nuevo, pero no teníamos nada sobre él aquí en LxA.

Evitar el GPG error editando el archivo sources.list

Hacerlo es bastante sencillo. Aquí vamos a poner como ejemplo el repositorio de Pipewire, con lo que se comenta que se soluciona el problema de Kooha que se congela en las últimas versiones (no fue mi caso en Jammy Jellyfish…). Para forzar la recarga, haríamos lo siguiente:

  1. Tenemos que añadir el repositorio en el archivo sources.list que está en /etc/apt, por lo que la manera más rápida es abrir un terminal y escribir:
sudo nano /etc/apt/sources.list
  1. Introducimos la contraseña de nuestro usuario.
  2. Ahora, al final añadiremos el repositorio y lo marcaremos como de confianza. En el caso del de Pipewire y para Ubuntu 21.10, o 22.04, ya que no existe la opción «jammy», añadiríamos lo siguiente:
deb [trusted=yes] http://ppa.launchpad.net/pipewire-debian/pipewire-upstream/ubuntu/ hirsute main
  1. Una vez añadido lo anterior, presionamos Ctrl+O para guardar, Intro para confirmar y Ctrl+X para salir.

De lo que hemos introducido, «[trusted=yes]» es lo que lo marca como de confianza, luego va la URL del repositorio y «hirsute» sería la marca de la versión, 21.10 en el caso de Ubuntu. Como hemos explicado, también funciona en Ubuntu 22.04, en donde da error sencillamente porque aún no está disponible para la versión que saldrá el próximo abril.

Y eso sería todo. Es un proceso sencillo que puede ahorrarnos muchos dolores de cabeza, pero no debemos descartar la posibilidad de que nos dé algún otro. Personalmente, sólo lo recomendaría para software que necesitemos y no esté disponible por otro medio, pero ahí queda la explicación.

from Linux Adictos https://ift.tt/3cxAZIp
via IFTTT