Las vulnerabilidades de Wi-Fi «FragAttacks» afectan a millones de dispositivos

Hace poco se dio a conocer la noticia sobre una serie de vulnerabilidades recién descubiertas en todos los dispositivos habilitados para Wi-Fi que se remontan desde hace más de 20 años y que permiten a un atacante robar datos si están dentro del alcance.

Esta serie de vulnerabilidades fueron descubiertas por el investigador de seguridad Mathy Vanhoef, las vulnerabilidades se denominan colectivamente «FragAttacks».

«Tres de las vulnerabilidades descubiertas son fallas de diseño en el estándar WiFi y, por lo tanto, afectan a la mayoría de los dispositivos», dijo Mathy Vanhoef, el investigador académico y de seguridad belga que descubrió los Frag Attacks.

El resto son vulnerabilidades causadas “por errores de programación generalizados [en la implementación del estándar WiFi] en productos WiFi”, dijo Vanhoef.

«Los experimentos indican que cada producto WiFi se ve afectado por al menos una vulnerabilidad y que la mayoría de los productos se ven afectados por varias vulnerabilidades», dijo Vanhoef, quien también está programado para dar una charla en profundidad sobre sus hallazgos a finales de este año en agosto en el USENIX. ’21 conferencia de seguridad.

Tal y como se mencionó tres de las vulnerabilidades son fallas de diseño en el estándar wifi y afectan a la mayoría de los dispositivos, mientras que las vulnerabilidades restantes son el resultado de errores de programación en los productos wifi.

La explotación de las vulnerabilidades puede permitir que un atacante dentro del alcance de la radio apunte a los dispositivos de varias formas. En un ejemplo, un atacante podría inyectar marcos de texto sin formato en cualquier red wifi segura. En otro ejemplo, un atacante podría interceptar el tráfico incitando a la víctima a utilizar un servidor DNS infectado.

Vanhoef señala que los experimentos indican que se puede encontrar al menos una vulnerabilidad en cada producto de wifi y que la mayoría de los productos se ven afectados por varias vulnerabilidades, ya que probó dispositivos con diversos dispositivos wifi, incluidos smartphones populares, tales como los Google,  Apple, Samsung y Huawei, asi como computadoras de Micro-Start International, Dell y Apple, dispositivos IoT de Canon y Xiaomi, entre otros más.

No hay evidencia de que las vulnerabilidades hayan sido explotadas en algún momento y al abordar el informe, Wi-Fi Alliance dijo que las vulnerabilidades se mitigan a través de actualizaciones de dispositivos de rutina que permiten la detección de transmisiones sospechosas o mejoran el cumplimiento de las prácticas recomendadas de implementación de seguridad.

“FragAttacks es un ejemplo clásico de cómo el software puede tener ambas vulnerabilidades de diseño y vulnerabilidades de ejecución,” 

“Antes de que alguien inicie un editor de código, la fase de diseño debe incluir principios de diseño seguro impulsados ​​por el modelado de amenazas… Durante la implementación y las pruebas, las herramientas de prueba de seguridad automatizadas ayudan a localizar las vulnerabilidades de seguridad para que puedan solucionarse antes del lanzamiento».

Las vulnerabilidades están catalogadas de la siguiente manera:

Defectos de diseño estándar de WiFi

  • CVE-2020-24588: ataque de agregación (acepta tramas A-MSDU que no son SPP).
  • CVE-2020-24587: ataque de clave mixta (reensamblaje de fragmentos cifrados bajo diferentes claves).
  • CVE-2020-24586: ataque de caché de fragmentos (no borrar fragmentos de la memoria cuando (re) conectarse a una red).

Defectos de implementación del estándar WiFi

  • CVE-2020-26145: Aceptación de fragmentos de transmisión de texto sin formato como fotogramas completos (en una red cifrada).
  • CVE-2020-26144: Aceptación de tramas A-MSDU de texto sin formato que comienzan con un encabezado RFC1042 con EtherType EAPOL (en una red cifrada).
  • CVE-2020-26140: Aceptación de marcos de datos de texto sin formato en una red protegida.
  • CVE-2020-26143: Aceptación de marcos de datos de texto plano fragmentados en una red protegida.

Otras fallas de implementación

  • CVE-2020-26139: Reenvío de tramas EAPOL aunque el remitente aún no esté autenticado (solo debería afectar a los AP).
  • CVE-2020-26146: Reensamblaje de fragmentos cifrados con números de paquete no consecutivos.
  • CVE-2020-26147: Reensamblaje de fragmentos mixtos cifrados / de texto sin formato.
  • CVE-2020-26142: Procesamiento de fotogramas fragmentados como fotogramas completos.
  • CVE-2020-26141: No se verifica el TKIP MIC de tramas fragmentadas.

Finalmente si estás interesado en conocer más al respecto, puedes consultar el siguiente enlace.

from Linux Adictos https://ift.tt/3y9F3YM
via IFTTT