Home > Cybersecurity > Vulnerability Found in GE Anesthesia Machines

Vulnerability Found in GE Anesthesia Machines

July 10, 2019

GE Healthcare has released a statement claiming the bug is not in the machine itself and does not pose direct risk to patients.

from Dark Reading: https://ift.tt/2S6D3vB
via IFTTT

%d bloggers like this: